En su instalación de PHP parece faltar la extensión de MySQL que requiere WordPress.